Predator Masters using UBB.threads ™ Infopop Corporation.
PM Gear Moon & Weather

Welcome to the Predator Masters Forums
Be sure to visit the main Predator Master website at





PM Gear
PM Gear
PM Gear
The Official Predator Masters Search Engine
Search Predator Masters

Topic Options
#3268287 - 01/29/21 09:25 PM Icotec stuttering issue
vmax_blaster Offline
Die Hard Member II

Registered: 12/30/03
Posts: 1227
Loc: Michigan
I have an Icotec sabre and every now and again it will seem to stutter. Like my first howl of the day it will stutter for a couple seconds and then be fine for the rest of the hunt. Go to my next spot and start out with a distress sound and it will stutter for a second and then be fine. Anybody have a similar issue? I'm using brand new energizer batteries.

Top
#3268876 - 02/03/21 05:12 PM Re: Icotec stuttering issue [Re: vmax_blaster]
Tooltime 2 Offline
Seasoned Member

Registered: 09/07/09
Posts: 192
Loc: N.W. Ohio
I would call them 419.867.6900 Chuck should be able to help you

Top
#3269435 - 02/07/21 12:38 PM Re: Icotec stuttering issue [Re: vmax_blaster]
Tooltime 2 Offline
Seasoned Member

Registered: 09/07/09
Posts: 192
Loc: N.W. Ohio
vmax did you get the problem figured out?

Top
#3275233 - 04/01/21 02:44 PM Re: Icotec stuttering issue [Re: Tooltime 2]
vmax_blaster Offline
Die Hard Member II

Registered: 12/30/03
Posts: 1227
Loc: Michigan
No. It doesn't do it all the time. I made about 10 stands with no issue then the next time out it would stutter on howls so I changed batteries and the next time out it did it again. Then went about 5 stands with no problems and went out this morning and first stand of the day let out a lone howl and started laughing, it stuttered the entire howl.

Top
#3275251 - 04/01/21 08:34 PM Re: Icotec stuttering issue [Re: vmax_blaster]
Coyote#1 Offline
Die Hard Member

Registered: 03/28/03
Posts: 673
Loc: KY
Don't have the sabre, but having the same issue with my 350.. Haven't used it much & thought it sounded like a speaker issue??
I got a extra speaker, ill get it out & see.. May just need broke in??

Top
#3275784 - 04/11/21 05:59 PM Re: Icotec stuttering issue [Re: vmax_blaster]
ShortStack Offline
Seasoned Member

Registered: 03/12/15
Posts: 113
Loc: AK
I've had a few Icotecs (outlaw,350 and 500) and can't seem to remember have a stuttering issue. I know some of the sounds might be choppy due to editing. Could possibly be the batteries? You could have try saving the actual sound files to a folder on the computer reformat the sd card. Upload the sound files back onto the card, sync the controller. Make sure not to save the non sound files when doing this. I would try that and see if that fixes it.
If the batteries are good and that doesn't help, there could be something wrong with some of the files or the unit. To which you'd want to contact JD at Icotec. Their customer service is very good.

Top




© Predator Masters™, All Rights Reserved. This material may not be published, broadcast, rewritten, or redistributed.